Adding Content Files with Akumina Yeoman Generator - Community forums - Akumina Community

Community forums

Forum Navigation
You need to log in to create posts and topics.

Adding Content Files with Akumina Yeoman Generator

Hello all:

I'm working with version 4.5. I created my deployment toolchain with the Akumina generator. I am able to upload other artifacts (js, css, pages, etc.) to SharePoint without any issue. However, whenever I try to upload widget view templates with the "contentfiles" option, I get this error:

DIRECTORY => BannerWidget
FOLDERNAME => Content
FullName => C:\Users\venJSnipe\source\Workspaces\SharePoint\BannerConnect\DEV\build\SiteDefinitions\DigitalWorkplaceCore\Branding\Content\Templates\BannerWidget
FileName => AATEST_Carousel.html
Error Executing Step: Add Content Files
StartIndex cannot be less than zero.
Parameter name: startIndex

My folder structure matches the structure in SharePoint (Content/Templates/WidgetName/). Has anyone seen this error and been able to figure out the issue?

Jermaine - in general to upload a widget view you should create an instance only widget via the command:

npm run stub

That way - the widget will upload witht he view properly assigned.

Thanks Scott. So to verify, if I need to update the view in the future I just need to cycle through npm (clean, build, package, deploy) for the instance that I already created and it will be updated in SharePoint?

Nevermind; I think I answered my own question. It looks like the view does update correctly for the partial instance. Thanks!

Great!

Quote from Jermaine Snipe on November 12, 2019, 4:40 pm

FileName => AATEST_Carousel.html
Error Executing Step: Add Content Files
StartIndex cannot be less than zero.
Parameter name: startIndex

My folder structure matches the structure in SharePoint (Content/Templates/WidgetName/). Has anyone seen this error and been able to figure out the issue?

 

For the specific error you're getting when deploying contentfiles replace the forward-slashes (/) with back-slashes (\) in your .env file envdir property.

It should look like this:

envdir=c:\some\path\to\envdir\

 

Thanks Mark; it looks like that solved the problem, and changing the direction of the slashes did not break the deployment of any of the other options in the toolchain. If I run into any other issues I'll reply to this post. Thanks again.

//]]>